Monday, October 18, 2010

The File AssemblyInfo.Cs could not be found within the project templates. Continuing to run, but the resulting project may not build properly.

Today after installing Visual Studio 2010 on a fresh copy of Windows 7 Enterprise, I encountered the following error message whenever I tried to create a new project using any project template: The File AssemblyInfo.Cs could not be found within the project templates. Continuing to run, but the resulting project may not build properly.

I think this may be due to the fact I accidentally installed a pre-release version of ReSharper 5.1 (I was meant to install the RTM version). Even after uninstalling ReSharper the problem did not go away.

To fix the issue, I simply ran this trusty old command: devenv.exe /InstallVSTemplates

Job done.

10 comments:

Anonymous said...

Thank you, it worked!

Anonymous said...

Thanks saved my day!

Anonymous said...

hi.... i have one doubt ....
Where i ran that command.... pls tell .....

Simon Hart said...

devenv.exe is Visual Studio IDE. So for VS 2012, the path is this:

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe.

Simon

Merdane said...

can't help writing a thanks message here

Thank you, saved my day too

Anonymous said...

Excellent! I was already afraid I had to reinstall VS. Thanks

Anonymous said...

I hope by leaving positive feedback I will help in improving your already excellent rank on the search engines.

In case you can't figure it out, it worked for me too!

Anonymous said...

Worked for me as well - awesome dude!

Anonymous said...

Me too - Brilliant.

Anonymous said...

Worked for me - Excellent.